标签归档:Python

MAC安装PIL

开始使用如下命令:

pip install pil

报如下错误

Collecting pil
  Could not find a version that satisfies the requirement pil (from versions: )
  Some externally hosted files were ignored as access to them may be unreliable (use --allow-external pil to allow).
No matching distribution found for pil

后来查了解决办法:见http://stackoverflow.com/questions/19532125/cant-install-pil-after-mac-os-x-10-9

使用如下步骤

pip install Pillow
ln -s ../Cellar/freetype/2.6_1/include/freetype2 freetype
pip install pil --allow-external pil --allow-unverified pil
pip install Pillow

成功安装

 

Centos升级python到2.7版本

开发部需要使用python2.7,由于公网的环境python版本都是系统自带的,版本是2.6,需要升级,最好是通过RPM升级。

实施步骤:

1. 下载linux 的release文件

wget http://li.nux.ro/download/nux/dextop/el6/i386/nux-dextop-release-0-2.el6.nux.noarch.rpm
rpm -ivh nux-dextop-release-0-2.el6.nux.noarch.rpm
yum -y install python27
yum -y install python27-devel

2. 升级python

#Centos默认还是使用python2.6.*,需要用python2.7的文件覆盖python文件。
cd /usr/bin/
rm -rf python
cp python2.7 python

3. 测试

在命令行里输入python --version,如果输出的结果显示的是这样就正确了:

4. 由于yum没有兼容python2.7,需要将下面红色的部分由 #!/usr/bin/python 修改为

#!/usr/bin/python2.6

5. 安装setuptools工具,方便自动升级

wget https://bootstrap.pypa.io/ez_setup.py -O - | python

6. 升级完成。

mac osx中python不能使用easy_install的解决办法

1. 检查easy_install的安装位置,正常情况下在/usr/bin或者/usr/local/bin中,要把找到的先删除,因为可能是版本不一致导致的不能使用。

sudo rm /usr/bin/easy_install*

sudo rm /usr/local/bin/easy_install*

2. 下载并且运行distribute

curl -O http://python-distribute.org/distribute_setup.py

sudo python distribute_setup.py

sudo rm distribute_setup.py

3. 使用easy_install测试安装pip

sudo easy_install pip

升级MAC OX上的Python到3.4版本

1. 下载最新的python3.4
下载Mac OS X 64-bit/32-bit installer
https://www.python.org/downloads/release/python-340/

2.安装DMG文件
安装下载的dmg文件

3. 配置

#!/bin/bash
#python版号需要修改两个地方
#1. new_version

#sudo -i #得到超级权限
new_version="3.4"

PYPATH=/System/Library/Frameworks/Python.framework/Versions/"$new_version"
#第1步移动新版python到mac默认目录下
echo "move.."
mv /Library/Frameworks/Python.framework/Versions/"$new_version" /System/Library/Frameworks/Python.framework/Versions/
#第2步改变用户目录的用户组
echo "chown.."
chown -R root:wheel ${PYPATH}
#第3步 删除原来2.7的链接
echo "del.."
rm /System/Library/Frameworks/Python.framework/Versions/Current
#第4步重新链接到最新版本的python
echo "ln.."
ln -s ${PYPATH} /System/Library/Frameworks/Python.framework/Versions/Current
#第5步删除旧的命令符号链接
echo "rm.."
rm /usr/bin/{pydoc,python,pythonw,python-config}
echo "ln bin.."
#第6步重新建立新的命令符号链接
ln -s ${PYPATH}/bin/pydoc"$new_version" /usr/bin/pydoc
ln -s ${PYPATH}/bin/python"$new_version" /usr/bin/python
ln -s ${PYPATH}/bin/pythonw"$new_version" /usr/bin/pythonw
ln -s ${PYPATH}/bin/python"$new_version"m-config /usr/bin/python-config


python_param_list=`cd /usr/local/bin && ls -al |grep "Python"|awk 'ORS=" " {print $9}'`
#第7步修复其他链接
for i in $python_param_list;do
  echo "info: $i"
  rm -f /usr/local/bin/${i}
  ln -sv /System/Library/Frameworks/Python.framework/Versions/"$new_version"/bin/${i} /usr/local/bin/${i}
done

#第8步.环境变量要修改为最新的版本号
echo 'export PATH=/System/Library/Frameworks/Python.framework/Versions/3.4/bin:${PATH}' >> ~/.bashrc

exit #退出超级权限

eclipse新建python项Project interpreter not specified

安装好pydev后新建python项目时提示”Project interpreter not specified“的错误,这是因为没有导入python开发环境报所引起。

解决方法:
1.找到eclipse---->“窗口”----->“首选项”.找到左侧栏边得pydev,展开,点击Interpreter-Python。
2.在右侧找到New,名字可以为空,找到python安装路径,我的是“E:\software\Python”.然后点击ok,等待导入完成,即可新建python项目